Commit 138ace6a authored by Alex ORLUC's avatar Alex ORLUC

add scripts + fix some params

parent 549015f4
......@@ -61,18 +61,13 @@
}
}
}
},
"maarchCourrier-e2e": {
"root": "",
"sourceRoot": "",
"projectType": "application"
}
},
"defaultProject": "maarchCourrier",
"schematics": {
"@schematics/angular:component": {
"prefix": "app",
"styleext": "css"
"styleext": "scss"
},
"@schematics/angular:directive": {
"prefix": "app"
......
......@@ -2,17 +2,19 @@
"name": "MaarchCourrier",
"description": "MaarchCourrier",
"scripts": {
"dep-list": "npm list --depth=0",
"build-css": "node-sass --include-path scss src/frontend/css/maarch-material.scss src/frontend/css/maarch-material.css --output-style compressed",
"build-prod": "ng build --prod && npm run build-css",
"build-watch": "ng build --watch",
"build": "ng build",
"check-update": "ncu",
"dep-list": "npm list --depth=0",
"upgrade": "ncu -u",
"build": "ng build",
"build-watch": "ng build --watch",
"build-prod": "ng build --prod && npm run build-css",
"build-css": "node-sass --include-path scss src/frontend/css/maarch-material.scss src/frontend/css/maarch-material.css --output-style compressed"
"create-component": "echo Component name ? && read varname && ng g c $varname --module app",
"create-component-admin": "echo Component name ? && read varname && ng g c administration/$varname --module administration"
},
"keywords": [],
"author": "Maarch",
"license": "GPL-3.0",
"license": "GPL-3.0",
"dependencies": {
"@fortawesome/fontawesome-free": "^5.11.2",
"@tinymce/tinymce-angular": "^3.4.0",
......@@ -20,17 +22,17 @@
"chart.js": "1.1.1",
"chosen-js": "^1.8.7",
"core-js": "^2.6.9",
"jquery": "^3.4.1",
"jquery-typeahead": "^2.11.0",
"jquery.nicescroll": "~3.6.8",
"jquery": "^3.4.1",
"jstree-bootstrap-theme": "^1.0.1",
"ng2-pdf-viewer": "^5.3.4",
"ngx-cookie-service": "^2.4.0",
"ngx-pipes": "^2.7.3",
"pdfjs-dist": "2.2.228",
"photoswipe": "^4.1.3",
"tinymce": "^5.1.6",
"tinymce-i18n": "^19.9.17",
"tinymce": "^5.1.6",
"tooltipster": "^4.2.7",
"uglify-es": "3.2.2",
"uglifyjs-webpack-plugin": "2.1.1",
......@@ -42,14 +44,14 @@
"@angular/cdk": "^8.2.0",
"@angular/cli": "^8.3.23",
"@angular/common": "^8.2.14",
"@angular/compiler": "^8.2.14",
"@angular/compiler-cli": "^8.2.14",
"@angular/compiler": "^8.2.14",
"@angular/core": "^8.2.14",
"@angular/forms": "^8.2.14",
"@angular/http": "^7.2.15",
"@angular/material": "^8.2.0",
"@angular/platform-browser": "^8.2.14",
"@angular/platform-browser-dynamic": "^8.2.14",
"@angular/platform-browser": "^8.2.14",
"@angular/platform-server": "^8.2.14",
"@angular/router": "^8.2.14",
"@types/datatables.net": "^1.10.18",
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment